/ / Soru 11
SoruYorum

Soru 11

11. sorumuzla devam edelim. Aşağıdaki gibi bir tablomuz var.

Soldaki tablodaki değerleri, sağdaki tablodaki gibi düzenlemek istiyoruz. 2 koşulumuz var. Hem biçim sayı olacak hem de hane sayısı 6 olacak.

Formül ya da makro ile yapabilirsiniz.

Dosyayı buradan indirebilir, cevaplarınızı yorum olarak yazabilirsiniz.


CEVAP

=EĞER(VE(UZUNLUK(A2)=6;ESAYIYSA(A2));”WW” & A2; A2)

Similar Posts

11 Comments

  1. =EĞER(VE(UZUNLUK(A2)=6;ESAYIYSA(A2));”WW”&A2;A2)

  2. =EĞER(VE(ESAYIYSA(A2);UZUNLUK(A2)=6);”WW”&A2;A2)

  3. =EĞER(VE(UZUNLUK(A2)=6;ESAYIYSA(A2));”WW”&A2;A2)

  4. Merhaba,
    Formül ile
    =EĞER(VE(UZUNLUK(A2)=6;ESAYIYSA(A2));”WW”&A2;A2)

    Makro ile
    Sub kod_duzenle()
    Range(“H2:H” & Range(“A” & Rows.Count).End(xlUp).Row).ClearContents
    For x = 2 To Range(“A” & Rows.Count).End(xlUp).Row
    If Len(Cells(x, “A”)) = 6 And IsNumeric(Cells(x, “A”)) Then
    Cells(x, “H”) = “WW” & Cells(x, “A”)
    Else
    Cells(x, “H”) = Cells(x, “A”)
    End If
    Next x
    End Sub

  5. Formül ile
    =+IF(AND(ISTEXT(A2)=FALSE;LEN(A2)=6);CONCATENATE(“WW”;A2);A2)
    veya
    =+IF(AND(ISNUMBER(A2)=TRUE;LEN(A2)=6);CONCATENATE(“WW”;A2);A2)

    Makro ile
    Sub deneme()

    For i = 2 To 10
    If IsNumeric(Cells(i, 1)) = True And Len(Cells(i, 1)) = 6 Then
    Cells(i, 8) = “WW” & Cells(i, 1)
    Else
    Cells(i, 8) = Cells(i, 1)
    End If
    Next i
    End Sub

  6. =EĞER(VE(UZUNLUK(A2)=6;ESAYIYSA(A2));”WW” & A2; A2)

  7. İyi akşamlar Musafa Hocam…

    Cevap : =EĞER(VE(ESAYIYSA(A2);UZUNLUK(A2=6));”WW”&A2;A2)

    Kolay gelsin…

  8. Bir yerde hata yapıyorum ama gecenin bu vakti durdu kafaaa…

    Private Sub ww()

    For i = 2 To 10

    If Cells(i, 1) = aplication.IsNumber Then Cells(i, 1) = “WW” & Cells(i, 1) Else GoTo atla

    atla:
    Next i

    End Sub

  9. =IF(LEN(A2)=6;IF(ISNUMBER(A2);CONCATENATE(“WV”;A2);A2);A2)

  10. =EĞER(VE(BAĞ_DEĞ_SAY(A2)=1;UZUNLUK(A2)=6);”WW”&A2;A2)

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.