Soru 15

282 defa okundu

15. sorumuzla devam edelim.

Aşağıdaki gibi bir tablomuz var. Bu tabloda bölgeler ve bölgelerdeki iller yer alıyor.

İstenen şey;

Rasgele bir şekilde, yeşil renkli hücrelere şehir isimleri getirilecek. Ancak herhangi bir şehir ismi değil.

Solunda yer alan bölge’nin herhangi bir şehri olacak. Şehir ismi birden fazla gelebilir. Ancak gelecek şehir ismi mutlaka solda yer alan bölgenin şehirlerinden biri olmalı.

Dosyayı buradan indirebilir, cevaplarınızı yorum olarak yazabilirsiniz.


CEVAP

=İNDİS(B:B;RASTGELEARADA(KAÇINCI(F2;A:A;0);KAÇINCI(F2;A:A;0)+EĞERSAY(A:A;F2)-1);0)

Bunlar da ilginizi çekebilir

  1. Abdullah ÖZDEM dedi ki:

    =İNDİS($B$2:$B$82;KAÇINCI(F2;$A$2:$A$82;0)+RASTGELEARADA(1;8))

  2. Ahmet Atasay dedi ki:

    =DÜŞEYARA($F2;$A:$B;2;0)

  3. Alper Düryaz dedi ki:

    =İNDİS(KAYDIR($A$1;KAÇINCI(E2;$A:$A;0)-1;1;EĞERSAY($A:$A;E2);1);RASTGELEARADA(1;EĞERSAY($A:$A;E2)))

  4. Murat BOZLAĞAN dedi ki:

    =DOLAYLI(“B”&RASTGELEARADA(KAÇINCI(F2;A:A;0);KAÇINCI(F2;A:A;0)+EĞERSAY(A:A;F2)-1))

  5. Yakup Alkan dedi ki:

    merhaba
    =İNDİS($B$1:$B$82;RASTGELEARADA(KAÇINCI(F2;$A$1:$A$82;0);KAÇINCI(F2;$A$1:$A$82;0)+EĞERSAY($A$1:$A$82;F2)-1);1)

  6. Murat Özlü dedi ki:

    =İNDİS($A:$B;RASTGELEARADA(KAÇINCI($F2;$A:$A;0);KAÇINCI($F2;$A:$A;0)+EĞERSAY($A:$A;$F2)-1);2)

  7. Nail S. dedi ki:

    Merhaba,
    G2 hücresine aşağıdaki formul yazılıp kopyalanır.

    =OFFSET($A$1;MATCH(F2;$A$2:$A$82;0)+RANDBETWEEN(0;COUNTIF($A:$A;F2)-1);1)

  8. şahin akpınar dedi ki:

    =KAYDIR($A$1;KAÇINCI(F2;$A$2:$A$82;0)+RASTGELEARADA(1;EĞERSAY($A$2:$A$82;F2))-1;1;1;1)

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.