Soru 2

692 defa okundu

Aşağıdaki gibi bir tablomuz var.

Bir müşterinin yaptığı alışverişe ilişkin olan bu tabloda; müşterinin farklı çeşit peynirler için ödediği toplam tutarı bulacağız.

Formül ve/veya makro kabul olmakla birlikte; filtreleme yaparak,elle manuel toplatarak vb. yöntemler kullanılarak yapılan çözümler kabul edilmemektedir 🙂

İdeal yöntem tek bir formülle yapmaktır.

Dosyayı buradan indirebilir, cevaplarınızı yoruma yazabilirsiniz.


CEVAP

Doğru sonuca ulaşan arkadaşları tebrik ederim.

En ideal çözüm;

=ETOPLA(B:B;”*peynir*”;C:C)

3. Soru ile devam etmek için tıklayın.

Bunlar da ilginizi çekebilir

  1. Adem Kürşat Karaçil dedi ki:

    +ETOPLA(B2:B11;”*”&”Peynir”&”*”;C2:C11) = 149

  2. HİLMİ dedi ki:

    =ETOPLA(B2:C11;”*Peynir*”;C2:C11)

  3. yusuf dedi ki:

    Sub mbb()

    For i = 2 To 11
    If Range(“b” & i) Like “*Peynir*” Then
    peynir = peynir + Range(“c” & i)
    End If
    Next i
    Range(“e5”) = “Peynir için Toplam Ödenen ” & peynir
    End Sub

    hocam sizin anlatımızla python sql serisi kurs görmeyi bekliyorum

  4. Muhammet Yunus dedi ki:

    =TOPLA(EĞER(ESAYIYSA(MBUL(“Peynir”; B2:B11));KAYDIR(B2:B11;;1);0))

    Ctrl+Shift+Enter yapmak şart.

  5. kadir dedi ki:

    Merhaba hocam

    formül =>>=ETOPLA(B2:B11;”*” & “Peynir” & “*”;C2:C11)

  6. Ahmet YAMAN dedi ki:

    =ETOPLA(B2:C11;”*peynir*”;C2:C11)

  7. Alper Düryaz dedi ki:

    =ETOPLA(B2:B11;”*Peynir*”;C2:C11)

    Peynir kelimesi bir hücreye yazılıp dinamik hale de getirilebilir.

  8. Harun dedi ki:

    =ETOPLA(B:B;”*peynir*”;C:C)

  9. HİLMİ dedi ki:

    Private Sub CommandButton1_Click()

    Range(“f13”) = WorksheetFunction.SumIf(Range(“b2:c11”), “*Peynir*”, Range(“c2:c11”))

    End Sub

  10. yusa dedi ki:

    Merhaba,

    D2 Hücresine =EĞERHATA(EĞER(MBUL(“Peynir”;B2)=D1;0;C2+D1);D1) yazıp süreklerim. Son satır toplamı verir.

    Kolay gelsin.

  11. TUTKU OZKAL dedi ki:

    =+SUMIFS(C2:C11,B2:B11,”*Peynir*”)

  12. TUTKU OZKAL dedi ki:

    =+SUMIF(B2:C11,”*Peynir*”,C2:C11)

  13. Sait dedi ki:

    İŞLEM SIRASI

    1 EĞERHATA(EĞER(BUL(G11;B2:B11);1;0);””)
    2 EĞER(D2=1;$G$11;0)
    3 ETOPLA(E:E;G11;C:C)

  14. ERDOĞAN dedi ki:

    VERİ DOĞRULAMA İLE İLK ÖNCE GRAMAJLARI AYIRIP SONRA ÜRÜN FİYATI İLE ÇARPIP TOPLAYARAK BULURUZ

  15. Yaşar Eser dedi ki:

    ETOPLA(B2:B11;”*pey*”;C2:C11)

  16. Burak Balcı dedi ki:

    =TOPLA.ÇARPIM(SOLDAN(B2:B11;4)/1000;C2:C11)

  17. Yılmaz Öztürk dedi ki:

    merhabalar,

    =ETOPLA(B2:B11;”*Peynir*”;C2:C11)

  18. Ahmet TEMÜR dedi ki:

    =ETOPLA(B:B;”*”&”peynir”&”*”;C:C)

  19. Melih dedi ki:

    F7=Peynir
    =SUMIFS(C2:C11,B2:B11,”*”&F7&”*”)=149

  20. Özgür dedi ki:

    1. Text to columns by ” ” delimiter
    2. Counta ile Peynir yazısı gelmeyenler ayrıştırılır.
    3. Counta 1 verenler için aritmatik işlem ile toplanır.

  21. S.Ali SEVİNÇ dedi ki:

    Sanırım en kısa çözüm bu..

    =ETOPLA(B2:$B$11;”*”&”Peynir”&”*”;C2:$C$11)

    Tüm arkadaşlara selamlar..

  22. MEHMET BÜLBÜL dedi ki:

    =DÜŞEYARA(B3;B2:C11;2;0)+DÜŞEYARA(B4;B2:C11;2;0)+DÜŞEYARA(B5;B2:C11;2;YANLIŞ)+DÜŞEYARA(B7;B2:C11;2;0)+DÜŞEYARA(B11;B2:C11;2;0)
    DAHA KISA YOLU VARDIR MUHTEMELEN.

  23. MURAT DÜNDAR dedi ki:

    Hayırlı Ramazanlar Mustafa Hocam. Böyle bir bölüm nerden aklınıza geldi bilmiyorum ama tek kelime ile müthiş… Umarım bu tip çok daha farklı aktivitelerle bizleri teşvik edersiniz. Gerçekten insan kullanmak zorunda kalmayınca bildiği şeyleri nerede nasıl kullanacağını veya hangi konularda eksik olduğunu bilemiyor. Tekrar teşekkürler…
    Cavabım : =ETOPLA(B:B;”*Peynir*”;C:C).

  24. RECEP GÜLSEVEN dedi ki:

    =ETOPLA(B2:B11;”*”&”Peynir”&”*”;C2:C11)

  25. Seyhun dedi ki:

    =IF(INDEX($I$2:$I$7;MATCH(1;–ISNUMBER(SEARCH($I$2:$I$7;B2));0))=$E$1;C2;””)

  26. Engin TUTKUN dedi ki:

    =ÇOKETOPLA(C2:C11;B2:B11;”*Peynir*”)

  27. bilal aydoğan dedi ki:

    =ETOPLA(B2:B11;”*peynir*”;C2:C11)

  28. sedat aksakal dedi ki:

    =ETOPLA(B2:B11;”*Peynir*”;C2:C11)

  29. Hale Kara dedi ki:

    Sub Soru2()
    For i = 2 To 11
    If InStr(Cells(i, “b”).Value, “Peynir”) > 0 Then
    Range(“d12”) = Range(“d12”) + Cells(i, “c”)
    End If

    Next i
    End Sub

  1. 06/05/2020

    […] Yeni soru burada… […]

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.