Soru 1

2.422 defa okundu

Merhaba Arkadaşlar,

Bugünden itibaren SoruYorum yapıyoruz. Yani önce bir soru soracağım. Sizler bu soru’nun cevabını yorum kısmına yazacaksınız. 24 saat sonunda, doğru cevap verenlerin ismini gururla yazacağız 🙂 Bunu her gün yapacağız.

En güzel öğrenme metodlarından biri sorulara cevap vermeye çalışmaktır. Bu nedenle böyle bir yöntem kullanmaya karar verdim. Kolay sorular olmayacak…

Cevaplar yine bu sayfada yer alacak. O nedenle sayfayı takipte kalın.

İlk sorumuza geçelim.

Böyle bir tablomuz var. Bu tablo’da İzmir ilinin 2018 ve 2019 toplamını istiyorum. İdeal bir yöntem var ancak tek yöntem yok. Tüm çözümler kabulümdür 🙂 (Formül ya da makro) E4+F4 gibi bir formül değil tabi kastettiğim 🙂

Yorumlarınızı aşağıda yazın. 24 saat sonra cevap için tekrar gelin…

Dosyayı buradan indirebilirsiniz.


Cevap

Birçok arkadaşımız çok farklı yöntemler kullanarak harika cevaplar vermişler. Dediğim gibi sonuca ulaşan tüm yöntemler doğrudur. Ancak direk hesap makinesi ile hesaplama yapanlar hariç 🙂

Burada ideal yöntem Kaydır(Offset) fonksiyonu kullanmaktır. 2 elemanlı bir dizi oluşturup, Toplama işlemi yapmamız yeterlidir.

=TOPLA(KAYDIR(A1;3;4;1;2))

Yeni soru burada…

Bunlar da ilginizi çekebilir

  1. Kubilay dedi ki:

    Merhabalar
    58.363

  2. Uğur Kaan Erdoğan dedi ki:

    =ÇOKETOPLA(E:E;A:A;J3)+ÇOKETOPLA(F:F;A:A;J3)

  3. Cabir dedi ki:

    Merhaba Hocam, ilk seçenek H sütununda =E4+F4 formulü ile işlem yaparım, diğer bir seçenek pivot tablodan bölge ve yılda 2 filtre uygulayarak toplam değeri bulabiliriz.
    Saygılarımla.

  4. Osman dedi ki:

    =+INDEX(B2:G7;MATCH(“İzmir”;A2:A7;0);MATCH(2017;B1:G1;0))+INDEX(B2:G7;MATCH(“İzmir”;A2:A7;0);MATCH(2018;B1:G1;0))

    • Osman dedi ki:

      yılları yanlış yazmışım 🙂

      =+INDEX(B2:G7;MATCH(“İzmir”;A2:A7;0);MATCH(2018;B1:G1;0))+INDEX(B2:G7;MATCH(“İzmir”;A2:A7;0);MATCH(2019;B1:G1;0))

  5. Uğur Kaan Erdoğan dedi ki:

    =DÜŞEYARA(J3;A1:G7;5;0)+DÜŞEYARA(J3;A1:G7;6;0)

  6. Emre Gökçadır dedi ki:

    =SUM(OFFSET(A1;MATCH(“İzmir”;A2:A7;0);MATCH(2018;B1:G1;0);1;2))

  7. Uğur Kaan Erdoğan dedi ki:

    =ETOPLA(A1:A7;J3;E1:E7)+ETOPLA(A1:A7;J3;F1:F7)

  8. Okan dedi ki:

    E4 F4 ARALIĞINI seçer excell in en altındaki toplam yazan yere bakarım. Eğer söylemek istediğiniz buysa

  9. Sina dedi ki:

    =VLOOKUP($A$11;$A$4:$G$4;5;0)+VLOOKUP($A$11;$A$4:$G$4;6;0) formülü ile bulunabilir hocam.Tabi ki A11=İzmir olmalı.

  10. UFUK ÇETİN dedi ki:

    2018 YILI İÇİN : İNDİS(E2:E4;KAÇINCI(A4;A2:A5;0);0)
    2019 YILI İÇİN : İNDİS(F2:F4;KAÇINCI(A4;A2:A4;0);0)

    hocam excel konusunda emeğiniz büyük. bende binlerce kez teşekkürler 🙂

  11. Tolga dedi ki:

    Selamlar Hocam, 2 adet ÇokETopla ile bir çözüm yaptım. 🙂
    =ÇOKETOPLA($E:$E;$A:$A;$J$3)+ÇOKETOPLA($F:$F;$A:$A;$J$3)

  12. Yılmaz Öztürk dedi ki:

    1. =ETOPLA($A$2:$A$7;$J$3;E$2:E$7)

    2. alt toplam

    3. pivot

    4. makro (kod yazmayı bilmek lazım)

  13. Abdullah Özdem dedi ki:

    Merhabalar hocam,

    =ÇOKETOPLA(F:F;A:A;”İzmir”)+ÇOKETOPLA(E:E;A:A;”İzmir”)
    =İNDİS(E:E;KAÇINCI(“izmir”;A:A;0))+İNDİS(F:F;KAÇINCI(“izmir”;A:A;0))
    =DÜŞEYARA(“izmir”;A:G;5;0)+DÜŞEYARA(“izmir”;A:G;6;0)
    =ÇAPRAZARA(“İzmir”;A:A;E:F)
    =KAYDIR($A$1;KAÇINCI(“İzmir”;A2:$A$7;0);KAÇINCI(2018;B1:G1;0))+KAYDIR($A$1;KAÇINCI(“İzmir”;A2:$A$7;0);KAÇINCI(2019;B1:G1;0))

  14. Utku Dülger dedi ki:

    Merhabalar,

    Çözümüm aşağıdkai gibi;

    Sub toplambul()

    ‘tanımlamalar

    Dim a As String

    Dim i As Integer

    Dim j As Integer

    Dim yil1 As Integer

    Dim yil2 As Integer

    Dim toplam As Double

    ‘kullanıcıdan veri isteme

    a = InputBox(“Toplamını bulmak istediğiniz Bölge’yi giriniz”)

    yil1 = InputBox(“Toplamını bulmak istediğiniz 1.yıl değerini giriniz”)

    yil2 = InputBox(“Toplamını bulmak istediğiniz 2.yıl değerini giriniz”)

    ‘değerleri tablo ile eşleştirip tolama işlemi yapma

    For i = 2 To 8

    If Cells(i, 1) = a Then

    For j = 2 To 7

    If Cells(1, j) = yil1 Then

    toplam = toplam + Cells(i, j).Value

    End If

    If Cells(1, j) = yil2 Then

    toplam = toplam + Cells(i, j).Value

    End If

    Next j

    End If

    Next i

    Cells(5, 10) = toplam

    End Sub

    ‘Biraz dinamiklik katmak için yıl ve şehir verilerini kullanıcıdan istedim. Sadece dediğiniz verileri bulmak için değişkenler yerine direct değerler yazılarak da işlem yapılabilir.

  15. Hasan Hüseyin HAN dedi ki:

    İNDİS(E2:E7+F2:F7;KAÇINCI(A4;A2:A7))

  16. Halit Tayfun Uğurlu dedi ki:

    Mustafa Hocam Merhaba;
    1- Düşeyara Fonksiyonu ile İzmir ilinin yıllara göre rakamlarını gösteren bir tablo oluşturulablir.
    2- Kaçıncı fonksiyonu ile İzmir, 2018,2019 vs. aranan değerin satır veya sütun sayısı belirlenir. İndis fonksiyonu ile belirlenen satır ve sütun sayısının kesişim noktasındaki değer okunabilir.
    3- Pivot tablo hazırlanıp dilimleyici eklenir. Aranan değerler dilimleyicilerdeki filtreleme yöntemleri kullanılarak bulunabilir. -kii bence en mantıklı ve kalıcı çözüm:)
    Saygılar.

  17. RECEP GÜLSEVEN dedi ki:

    =ETOPLA(A2:A7;A4;E2:E7)+ETOPLA(A2:A7;A4;F2:F7)

  18. Mert A. dedi ki:

    =DÜŞEYARA(J3;A1:G7;KAÇINCI(E1;A1:G1);0)+DÜŞEYARA(J3;A1:G7;KAÇINCI(F1;A1:G1);0)

    Muhtemelen ideal çözüm değildir ama sonucu veriyor 🙂

    Saygılar.

  19. HİLMİ dedi ki:

    =KAYDIR(A1;KAÇINCI(“izmir”;A2:A7);KAÇINCI(2018;A1:G1)-1;1;1)+KAYDIR(A1;KAÇINCI(“izmir”;A2:A7);KAÇINCI(2019;A1:G1)-1;1;1)

  20. Ümit Güzel dedi ki:

    Çözüm1: =(ÇOKETOPLA(E2:E7;A2:A7;A4)+ÇOKETOPLA(F2:F7;A2:A7;A4))

    Çözüm2:=TOPLA(DÜŞEYARA(J3;A:E;5;0);DÜŞEYARA(A4;A:F;6;0))

  21. Abdullah Özdem dedi ki:

    Hocam Merhabalar Bir yolunu daha buldum Güncelleme istiyorum ;

    =ÇOKETOPLA(F:F;A:A;”İzmir”)+ÇOKETOPLA(E:E;A:A;”İzmir”)
    =İNDİS(E:E;KAÇINCI(“izmir”;A:A;0))+İNDİS(F:F;KAÇINCI(“izmir”;A:A;0))
    =DÜŞEYARA(“izmir”;A:G;5;0)+DÜŞEYARA(“izmir”;A:G;6;0)
    =ÇAPRAZARA(“İzmir”;A:A;E:F)
    =KAYDIR($A$1;KAÇINCI(“İzmir”;A2:$A$7;0);KAÇINCI(2018;B1:G1;0))+KAYDIR($A$1;KAÇINCI(“İzmir”;A2:$A$7;0);KAÇINCI(2019;B1:G1;0))
    =TOPLA(EĞER((A2:A7=”İzmir”)*(B1:G1=2018);(E2:E7));EĞER((A2:A7=”İzmir”)*(B1:G1=2019);(F2:F7)))

  22. CAN dedi ki:

    =TOPLA(DÜŞEYARA(A4;A1:G7;5;0);DÜŞEYARA(A4;A1:G7;6;0))

  23. ERDOĞAN dedi ki:

    INDEX-MATCH FORMÜLÜ İLE BULABİLİRİZ.

  24. kadir dedi ki:

    Merhaba hocam öncelikle bu tarz bir uygulamaya geçtiğiniz için çok teşekkür ederim , arayıpta bulamadığım bir şeydi ve mail de de birkaç gün önce sizden ödev isteğim olmuştu.

    Bir kaç farklı formül ile yaptım ama VBA tarafında yapamadım maalesef.

    =DÜŞEYARA(I2;A1:G7;KAÇINCI(I4;A1:G1;0);YANLIŞ)+DÜŞEYARA(I2;A1:G7;KAÇINCI(I3;A1:G1;0);YANLIŞ)

    =TOPLA.ÇARPIM((I2=A2:A7)*(I4=B1:G1)*(B2:G7))+TOPLA.ÇARPIM((I2=A2:A7)*(I3=B1:G1)*(B2:G7))
    ctrl+shift+enter yaparak küme içerisine alınır

    =İNDİS(A1:G7;KAÇINCI(I2;A1:A7;0);KAÇINCI(I4;A1:G1;0))+İNDİS(A1:G7;KAÇINCI(I2;A1:A7;0);KAÇINCI(I3;A1:G1;0))

    =TOPLA((I2=A2:A7)*(I3=B1:G1)*(B2:G7))+TOPLA((I2=A2:A7)*(I3=B1:G1)*(B2:G7))
    ctrl+shift+enter yaparak küme içerisine alınır

    =KAYDIR(A1;KAÇINCI(I2;A2:A7;0);KAÇINCI(I3;B1:G1;);;)+KAYDIR(A1;KAÇINCI(I2;A2:A7;0);KAÇINCI(I4;B1:G1;);;)

    illeri liste kutusundan seçerek yaptım yılları manuel yazdım …

  25. Ömer can dedi ki:

    =Topla(E4;F4)

  26. Mahmut dedi ki:

    =E4+F4

    =SUM(E4:F4)

    =INDEX(B2:G7;MATCH(J3;A2:A7;0);MATCH(2018;B1:G1;0))+INDEX(B2:G7;MATCH(J3;A2:A7;0);MATCH(2019;B1:G1;0))

    =SUM(XLOOKUP(A4;A1:A7;F1:F7);XLOOKUP(A4;A1:A7;E1:E7))

    =SUMPRODUCT((B1:G12017)*B4:G4)

  27. Mahmut dedi ki:

    =SUMPRODUCT((B1:G12017)*B4:G4)

    =E4+F4

    =SUM(E4:F4)

    =INDEX(B2:G7;MATCH(J3;A2:A7;0);MATCH(2018;B1:G1;0))+INDEX(B2:G7;MATCH(J3;A2:A7;0);MATCH(2019;B1:G1;0))

    =SUM(XLOOKUP(A4;A1:A7;F1:F7);XLOOKUP(A4;A1:A7;E1:E7))

  28. Sait dedi ki:

    =DÜŞEYARA(J5;A:G;KAÇINCI(L4;A1:G1;0);0)+(DÜŞEYARA(J5;A:G;KAÇINCI(K4;A1:G1;0);0))

    J5 = Bölge Adı
    K4 = 1.Tarih
    L4 = 2.Tarih

  29. Özkan Sabancı dedi ki:

    Hocam selam,

    Çok düşünmeden aşağıdaki şekilde çözmeye çalıştım. J5 hücresine aşağıdaki formülü yazdım. (Gerçi fark etmez nereye yazacağımız :))

    İyi Çalışmalar.

    =TOPLA(İNDİS(FİLTRE(B2:G7;A2:A7=$J$3);1;4);İNDİS(FİLTRE(B2:G7;A2:A7=$J$3);1;5))

  30. Esra ÖZAY dedi ki:

    58.363

  31. Barbaros Demirsoy dedi ki:

    =DÜŞEYARA( “İzmir”;A1:G7;((KAÇINCI(2018;A1:G1)));YANLIŞ) +DÜŞEYARA(“İzmir”;A1:G7;((KAÇINCI(2019;A1:G1)));YANLIŞ)

  32. yusuf dedi ki:

    =İNDİS($E$1:$E$7;KAÇINCI(“İzmir”;$A$1:$A$7;0))+İNDİS($F$1:$F$7;KAÇINCI(J3;$A$1:$A$7;0))

    eğitimlerinizi ilgiyle takip ediyorum .

  33. Ali dedi ki:

    +OFFSET($A$1;MATCH(“İzmir”;$A:$A;0);MATCH(“2018”;$1:$1;0);1;1)+INDEX($B$2:$G$7;MATCH(“İzmir”;$A:$A;0);MATCH(“2019”;$1:$1;0);1;1)

  34. yusa dedi ki:

    =ÇOKETOPLA(E:E;A:A;”izmir”)+ÇOKETOPLA(F:F;A:A;”izmir”)

    Tek formülle yapılabiliyorsa doğru kabul etmiyorum 🙂

  35. sedat aksakal dedi ki:

    =ETOPLA(A2:A7;A9;E2:E7)+ETOPLA(A2:A7;A9;F2:F7)

    izmir (A9) hücresindedir.

  36. Burak Balcı dedi ki:

    Hocam iki farklı formülle çözdüm. İdeal çözümü merakla bekliyorum.
    =TOPLA(ETOPLA(A:G;A4;E:E);ETOPLA(A:G;A4;F:F))
    =TOPLA(KAYDIR(A1;KAÇINCI(A4;A:A;0)-1;KAÇINCI(E1;A1:G1;0)-1;1;2))

  37. SERHAT dedi ki:

    Önce b13 hücresine Bölge onun altınada İzmir yazarım. Aşağıdaki örnekte b13 ve b14 hücreleri olarak. Veritabanı formulü ile toplarım.

    =VSEÇTOPLA(A1:G8;”2018″;B13:B14)+VSEÇTOPLA(A1:G8;”2019″;B13:B14)

  38. HİLMİ dedi ki:

    =DOLAYLI(ADRES(KAÇINCI(“İzmir”;A1:$A$7;0);KAÇINCI(2018;A1:G1;0);1;1))+DOLAYLI(ADRES(KAÇINCI(“İzmir”;A1:$A$7;0);KAÇINCI(2019;A1:G1;0);1;1))

  39. Ahmet YAMAN dedi ki:

    =ÇOKETOPLA(E:E;A:A;”İzmir”)+ÇOKETOPLA(F:F;A:A;”İzmir”)
    Umarım doğrudur sonuç 58,363:)

  40. MEHMET BÜLBÜL dedi ki:

    =KAYDIR(A1;KAÇINCI(H11;A2:A7;0);KAÇINCI(I11;B1:G1;0);1;1)+KAYDIR(A1;KAÇINCI(A4;A2:A7;0);KAÇINCI(F1;B1:G1;0);1;1)

  41. MEHMET BÜLBÜL dedi ki:

    =DÜŞEYARA(A4;A1:G7;5;YANLIŞ)+DÜŞEYARA(A4;A1:G7;6;YANLIŞ)

  42. Engin TUTKUN dedi ki:

    =ETOPLA(A2:A7;A4;E2:E7) + ETOPLA(A2:A7;A4;F2:F7)

  43. Yaman Gürkaynak dedi ki:

    2018 için:=DÜŞEYARA(A4;A1:G7;5)
    2019 için:=DÜŞEYARA(A4;A1:G7;6)
    Yazarsak buluruz derim.

  44. Atilla Kara dedi ki:

    Merhabalar hocam
    Benim cevabım
    =TOPLA(+DÜŞEYARA(“İZMİR”;A1:G7;{5;6};0))
    hücreye yazıp Ctrl+Shift+Enter birlikte basıyoruz.

  45. Ahmet TEMÜR dedi ki:

    =+ETOPLA(A2:A7;”İzmir”;E2:E7)+ETOPLA(A2:A7;”İzmir”;F2:F7)

  46. bilal aydoğan dedi ki:

    hocam hayırlı akşamlar eğer soruyu yanlış anlamadıysam sonuç =TOPLA.ÇARPIM(E2:F7)

  47. Tutku ÖZKAL dedi ki:

    1. Yol =+TOPLA.ÇARPIM(((A2:A7=A4)*E2:E7)+(A2:A7=A4)*F2:F7)
    2. Yol =+İNDİS(A1:G7;KAÇINCI(A4;A1:A7;0);KAÇINCI(F1;A1:G1;0))+İNDİS(A1:G7;KAÇINCI(A4;A1:A7;0);KAÇINCI(E1;A1:G1;0))
    3. Yol =+TOPLA.ÇARPIM(((A2:A7=A4)*E2:E7)+(A2:A7=A4)*F2:F7) en sadesi
    ayrıca düşey ara ve çoketopla formüllerini 1. ve 2. yolda olduğu üzere arka arkaya yaparak vb. bulunması mümkün. En az 5 farklı yöntem vba kısmı hariç tabiki.
    ad tanımlamaları ile de bu formülleri kısaltmak mümkün olabilir.

  48. Beste Imamoğlu dedi ki:

    =TOPLA(E4+F4)

  49. Halilcan dedi ki:

    A9=Düşeyara(A8;A1:G7;4;0)+Düşeyara(A8;A1:G7;5;0)
    Şeklinde bulabiliriz hocam

  50. S.Ali Sevinç dedi ki:

    Formülle Çözüm :

    =İNDİS(tablo;KAÇINCI(“İzmir”;bolge;0)+1;KAÇINCI(2018;tarih;0)+1)+İNDİS(tablo;KAÇINCI(“İzmir”;bolge;0)+1;KAÇINCI(2019;tarih;0)+1)

    sonuç : 58.363

    Ad tanımlama kullanılmıştır..
    tablo = Sayfa1!$A$1:$G$7
    tarih = Sayfa1!$B$1:$G$1
    bolge = Sayfa1!$A$2:$A$7

  51. Okan dedi ki:

    İki hücreyi seçip Excel in aşağıdaki statü bar da toplam görünür.

  52. MUHAMMET YAVUZ AKYOL dedi ki:

    =ETOPLA(A2:A7;A4;E2:E2:E7)+ETOPLA(A2:A7;A4;F2:F7)

  53. Sub topla()

    Dim a As Long

    Dim b As Long

    Dim sonuc As Long

    a = Range(“e4”)

    b = Range(“f4”)

    sonuc = WorksheetFunction.Sum(Range(“e4”, “f4”))

    MsgBox “Toplam” & sonuc

    End Sub

  54. Nihan dedi ki:

    Çoketopla formülü ile

  55. Melih üstün dedi ki:

    Merhaba Hocam
    Ben bu sekilde buldum
    =OFFSET(A1,3,4,1,1)+OFFSET(A1,3,5,1,1) =58363

  56. b nokta g dedi ki:

    =(DÜŞEYARA(“İzmir”;A1:G7;(SÜTUNSAY(B1:G7)-1);YANLIŞ))+(DÜŞEYARA(“İzmir”;A1:G7;(SÜTUNSAY(B1:G7));YANLIŞ))

  57. Yusuf PINARBAŞI dedi ki:

    E madem tüm çözümler kabul ediliyor ben şöyle yaptım. İstenilen 2 veriden ibaret bir bilgi olduğu için formül yazmaya üşendim 26.653 ile 31.710’u hesap makinesiyle topladım. Sonuç 58.363

    PEKİ BUNU NİYE YAPTIM? Sizden istenilen bilgi bazen acil istenebiliyor. O yüzden strese girmeden sonuca giden en kestirme yolu kullanmanız gerekir. Velhasıl Formül kullanmamak da bir formüldür.

  58. A10 iZMİR
    A11 2018
    A12 2019

    SONUÇ==KAYDIR($A$1;KAÇINCI($A$10;$A$2:$A$7;0);KAÇINCI($A$11;$B$1:$G$1;0);1;1)+KAYDIR($A$1;KAÇINCI($A$10;$A$2:$A$7;0);KAÇINCI($A$12;$B$1:$G$1;0);1;1)

  59. Ahmet karaçay dedi ki:

    Hocam merhaba, benim aklıma 2 yöntem geldi
    birincisi herhangi hücreye =TOPLA(E4:F4) yapzıp toplamı çıkartmak
    ikincisi ise aşağıdak gibi bir butona makro atayıp çalıştırarak toplama
    Sub topla()

    ‘ topla Makro


    Range(“M4”).Select
    ActiveCell.FormulaR1C1 = “=SUM(RC[-8]+RC[-7])”
    Range(“M5”).Select
    End Sub

  60. Tayfun BATUR dedi ki:

    Hocam Merhaba,

    Udemy öğrenciniz Tayfun Batur ben. Sizin sormuş olduğunuz soruyu ben kendi mantığımla cevapladım.

    2018 – 2019 İzmir verisini elde etmek için ilk önce 2 farklı hücrede çoketopla fonksiyonu kullanarak izmir’in rakamlarını elde ettikten sonra toplam sonucu görmek içinde 2018(sonuç) + 2019(sonuç) = 58,363

    Formüller Şöyle;

    2018 Yılı İçin; =ÇOKETOPLA(E:E;A:A;”İzmir”)

    2019 Yılı İçin; =ÇOKETOPLA(F:F;A:A;”İzmir”)

    Toplam Rakam İçin; =J2+K2

  61. NİDA YILMAZ dedi ki:

    cevap: 58.363
    =TOPLA(E4:F4)

  62. Danış Özer Ay dedi ki:

    Merhaba Mustafa Bey,

    Belırttıgınız gıbı sonuca goturecek formu cok ama hızlıca aklıma gelen 4 farklı metodu sızınle paylaşmak ıstedım.

    BİRİNCİ ÇÖZÜM
    =ETOPLA(A2:A7;A4;E2:E7)+ETOPLA(A2:A7;A4;F2:F7)

    İKİNCİ ÇÖZÜM
    =DÜŞEYARA(A4;A1:G7;5;YANLIŞ)+DÜŞEYARA(A4;A1:G7;6;YANLIŞ)

    ÜÇÜNCÜ ÇÖZÜM
    =DÜŞEYARA(“İZMİR”;A2:G7;5;YANLIŞ)+DÜŞEYARA(“İZMİR”;A2:G7;6;YANLIŞ)

    DÖRDÜNCÜ ÇÖZÜM
    =ÇOKETOPLA(E2:E7;A2:A7;A4)+ÇOKETOPLA(F2:F7;A2:A7;A4)

    Saygılarımla

    Danış Özer Ay

  63. Muhammet Yunusq dedi ki:

    Merhaba hocam, kolay gelsin.
    Öncelikle çok iyi düşünmüşsünüz. Tebrikler.

    Benim çözümüm: =SUMPRODUCT(((A2:A7=J3)*(B1:G1>=K3)*(B1:G1<=L3)*(B2:G7)))

    Tabi burada
    J3'e aramak istediğimiz şehri
    K3'e başlangıç yılını
    L3'e bitiş yılını yazıyoruz.

    Örnek dosya linkini aşağıda internet sitesi kısmına yazıyorum.

    Kolay gelsin.

  64. Selim dedi ki:

    Private Sub CommandButton1_Click()
    For i = 2 To 7

    If Cells(i, 1) = “İzmir” Then
    For k = 2 To 7
    If Cells(1, k) = “2018” Or Cells(1, k) = “2019” Then
    toplam = toplam + Cells(i, k)
    End If
    Next k
    End If
    Next i

    MsgBox toplam

    End Sub

  65. Mustafa İSMİL dedi ki:

    =ÇOKETOPLA(F:F;A:A;”izmir”)+ÇOKETOPLA(E:E;A:A;”izmir”)

    =DÜŞEYARA(A4;A2:F7;5;0)+DÜŞEYARA(A4;A2:F7;6;0)

  66. Hale Kara dedi ki:

    =VLOOKUP(J3;A1:G7;COLUMN(E1))+VLOOKUP(J3;A1:G7;COLUMN(F1))

  67. KAZIM dedi ki:

    yatayara ve kaçıncı fonksiyonlaırnı kullanarak yaptım. şehiri ve yılları girerek toplama ulşaşabiliriz.

    City : İzmir
    year 1 2018 =IF(H12=””;””;HLOOKUP(H12;$A$1:$G$7;MATCH($H$11;$A$1:$A$7)))
    year 2 2019 =IF(H13=””;””;HLOOKUP(H13;$A$1:$G$7;MATCH($H$11;$A$1:$A$7)))
    year 3 =IF(H14=””;””;HLOOKUP(H14;$A$1:$G$7;MATCH($H$11;$A$1:$A$7)))
    year 4 =IF(H15=””;””;HLOOKUP(H15;$A$1:$G$7;MATCH($H$11;$A$1:$A$7)))
    year 5 =IF(H16=””;””;HLOOKUP(H16;$A$1:$G$7;MATCH($H$11;$A$1:$A$7)))
    year 6 =IF(H17=””;””;HLOOKUP(H17;$A$1:$G$7;MATCH($H$11;$A$1:$A$7)))
    =SUM(I12:I17)

  68. Alper Düryaz dedi ki:

    =İNDİS(A1:G7;KAÇINCI(“izmir”;A1:A7;0);KAÇINCI(2018;A1:G1;0))+İNDİS(A1:G7;KAÇINCI(“izmir”;A1:A7;0);KAÇINCI(2019;A1:G1;0))

  69. Danış Özer Ay dedi ki:

    Boşta kalınca olabılecek en uzun formul ıle hesaplamak ıstedım. İdeal bır if/or egzersizi olur deneyen arkadaşlara 🙂

    BEŞİNCİ ALTERNATİF

    =(EĞER(VE(A2=”izmir”;YADA(B1=2018;B1=2019));B2;0)+(EĞER(VE(A2=”izmir”;YADA(C1=2018;C1=2019));C2)+(EĞER(VE(A2=”izmir”;YADA(D1=2018;D1=2019));D2)+(EĞER(VE(A2=”izmir”;YADA(E1=2018;E1=2019));E2)+(EĞER(VE(A2=”izmir”;YADA(F1=2018;F1=2019));F2)+(EĞER(VE(A2=”izmir”;YADA(G1=2018;G1=2019));G2)+(EĞER(VE(A3=”izmir”;YADA(B1=2018;B1=2019));B3)+(EĞER(VE(A3=”izmir”;YADA(C1=2018;C1=2019));C3)+(EĞER(VE(A3=”izmir”;YADA(D1=2018;D1=2019));D3)+(EĞER(VE(A3=”izmir”;YADA(E1=2018;E1=2019));E3)+(EĞER(VE(A3=”izmir”;YADA(F1=2018;F1=2019));F3)+(EĞER(VE(A3=”izmir”;YADA(G1=2018;G1=2019));G3)+(EĞER(VE(A4=”izmir”;YADA(B1=2018;B1=2019));B4)+(EĞER(VE(A4=”izmir”;YADA(C1=2018;C1=2019));C4)+(EĞER(VE(A4=”izmir”;YADA(D1=2018;D1=2019));D4)+(EĞER(VE(A4=”izmir”;YADA(E1=2018;E1=2019));E4)+(EĞER(VE(A4=”izmir”;YADA(F1=2018;F1=2019));F4)+(EĞER(VE(A4=”izmir”;YADA(G1=2018;G1=2019));G4)+(EĞER(VE(A5=”izmir”;YADA(B1=2018;B1=2019));B5)+(EĞER(VE(A5=”izmir”;YADA(C1=2018;C1=2019));C5)+(EĞER(VE(A5=”izmir”;YADA(D1=2018;D1=2019));D5)+(EĞER(VE(A5=”izmir”;YADA(E1=2018;E1=2019));E5)+(EĞER(VE(A5=”izmir”;YADA(F1=2018;F1=2019));F5)+(EĞER(VE(A5=”izmir”;YADA(G1=2018;G1=2019));G5)+(EĞER(VE(A6=”izmir”;YADA(B1=2018;B1=2019));B6)+(EĞER(VE(A6=”izmir”;YADA(C1=2018;C1=2019));C6)+(EĞER(VE(A6=”izmir”;YADA(D1=2018;D1=2019));D6)+(EĞER(VE(A6=”izmir”;YADA(E1=2018;E1=2019));E6)+(EĞER(VE(A6=”izmir”;YADA(F1=2018;F1=2019));F6)+(EĞER(VE(A6=”izmir”;YADA(G1=2018;G1=2019));G6)+(EĞER(VE(A7=”izmir”;YADA(B1=2018;B1=2019));B7)+(EĞER(VE(A7=”izmir”;YADA(C1=2018;C1=2019));C7)+(EĞER(VE(A7=”izmir”;YADA(D1=2018;D1=2019));D7)+(EĞER(VE(A7=”izmir”;YADA(E1=2018;E1=2019));E7)+(EĞER(VE(A7=”izmir”;YADA(F1=2018;F1=2019));F7)+(EĞER(VE(A7=”izmir”;YADA(G1=2018;G1=2019));G7;0)))))))))))))))))))))))))))))))))))))

  70. levent dolgun dedi ki:

    =+ETOPLA(A2:A7;A4;E2:E7)+ETOPLA(A2:A7;A4;F2:F7)

    Hocam mevcut excel bigilerimle ulastığım sonuc bu 🙂

Bir cevap yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

This site uses Akismet to reduce spam. Learn how your comment data is processed.